# Confluent Cloud

**URL:** https://forum.confluent.io/c/confluent-cloud/5.md

[Latest](https://forum.confluent.io/latest.md) · [Categories](https://forum.confluent.io/categories.md)

---

## [Kafka Connect in Confluent Cloud? Sure!](https://forum.confluent.io/t/kafka-connect-in-confluent-cloud-sure/191)

<div class="topic-metadata">

**Author:** [@rmoff](https://forum.confluent.io/u/rmoff)\
**Replies:** 0\
**Last updated:** [17 November 2020 17:52 UTC](https://forum.confluent.io/t/kafka-connect-in-confluent-cloud-sure/191 "2020-11-17T17:52:22Z")

</div>

:point\_right: Head over to the Managed Connectors category

---

## [Getting started with Confluent Cloud for free (and how do I skip the paywall?)](https://forum.confluent.io/t/getting-started-with-confluent-cloud-for-free-and-how-do-i-skip-the-paywall/48)

<div class="topic-metadata">

**Author:** [@rmoff](https://forum.confluent.io/u/rmoff)\
**Replies:** 1\
**Last updated:** [27 August 2025 17:14 UTC](https://forum.confluent.io/t/getting-started-with-confluent-cloud-for-free-and-how-do-i-skip-the-paywall/48 "2025-08-27T17:14:51Z")

</div>

Confluent Cloud is the industry’s only cloud-native, fully managed event streaming platform powered by Apache Kafka. Stream data and connect systems and applications with just a few clicks. Scale Apache Kafka® work…

---

## [What does each Confluent Cloud invoice line\_type actually bill for? Sanity-checking my mapping](https://forum.confluent.io/t/what-does-each-confluent-cloud-invoice-line-type-actually-bill-for-sanity-checking-my-mapping/38509)

<div class="topic-metadata">

**Author:** [@mithrandirr](https://forum.confluent.io/u/mithrandirr)\
**Replies:** 2\
**Last updated:** [7 September 2026 18:27 UTC](https://forum.confluent.io/t/what-does-each-confluent-cloud-invoice-line-type-actually-bill-for-sanity-checking-my-mapping/38509 "2026-09-07T18:27:22Z")

</div>

I’ve been reconciling Confluent Cloud invoices line by line, mapping every line\_type in the billing CSV to what it actually meters. I’d like to check my understanding before relying on it. line\_type I think it bills …

---

## [Low volume compact topic not deleting old messages](https://forum.confluent.io/t/low-volume-compact-topic-not-deleting-old-messages/38438)

<div class="topic-metadata">

**Author:** [@ernesto.costa](https://forum.confluent.io/u/ernesto.costa)\
**Replies:** 1\
**Last updated:** [22 June 2026 21:23 UTC](https://forum.confluent.io/t/low-volume-compact-topic-not-deleting-old-messages/38438 "2026-06-22T21:23:36Z")

</div>

Hi, We’re having some difficulties when it comes to topics with low volume of messages being sent to them and compaction. Example: the topic has the following settings: cleanup.policy compact delete.retention…

---

## [Jetty version mismatch](https://forum.confluent.io/t/jetty-version-mismatch/38291)

<div class="topic-metadata">

**Author:** [@Smrutiranjan209](https://forum.confluent.io/u/Smrutiranjan209)\
**Replies:** 2\
**Last updated:** [9 April 2026 11:13 UTC](https://forum.confluent.io/t/jetty-version-mismatch/38291 "2026-04-09T11:13:22Z")

</div>

Hi Team, We are currently using kafka-schema-registry-client version 8.1.1, which depends on Jetty 9.4.58.v20250814. We would like to know if there are any plans to upgrade Jetty to the 12.0.x series in upcoming releas…

---

## [Billing issue – No response on support ticket #347335](https://forum.confluent.io/t/billing-issue-no-response-on-support-ticket-347335/38330)

<div class="topic-metadata">

**Author:** [@tanu-ns](https://forum.confluent.io/u/tanu-ns)\
**Replies:** 1\
**Last updated:** [7 April 2026 16:33 UTC](https://forum.confluent.io/t/billing-issue-no-response-on-support-ticket-347335/38330 "2026-04-07T16:33:27Z")

</div>

Hi, I opened a billing support request (#347335) regarding a $369.33 charge on my Confluent Cloud account, but I have not yet received a response. This usage was accidental during a workshop, and I have already deleted…

---

## [Max Partitions missing from Cluster display](https://forum.confluent.io/t/max-partitions-missing-from-cluster-display/38268)

<div class="topic-metadata">

**Author:** [@richship](https://forum.confluent.io/u/richship)\
**Replies:** 4\
**Last updated:** [2 March 2026 17:09 UTC](https://forum.confluent.io/t/max-partitions-missing-from-cluster-display/38268 "2026-03-02T17:09:49Z")

</div>

Looks like there has been a change in the Cluster Overview page. It used to show “xxxx partitions used of yyyy available” or similar, but now only shows the partitions used. Is there still a way to show the maximum part…

---

## [Migrating v new installation (v.2.x) to old](https://forum.confluent.io/t/migrating-v-new-installation-v-2-x-to-old/38205)

<div class="topic-metadata">

**Author:** [@infntypro62](https://forum.confluent.io/u/infntypro62)\
**Replies:** 0\
**Last updated:** [26 December 2025 12:57 UTC](https://forum.confluent.io/t/migrating-v-new-installation-v-2-x-to-old/38205 "2025-12-26T12:57:20Z")

</div>

I tried to find instructions about the upgrade, but it looks like 5 → 6 is old. The opposite documents do not show any information about the upgrade path. What is the truth behind that?

---

## [Feasibility of Using Confluent Cloud Schema Registry with GCP Managed Kafka](https://forum.confluent.io/t/feasibility-of-using-confluent-cloud-schema-registry-with-gcp-managed-kafka/38182)

<div class="topic-metadata">

**Author:** [@Archita](https://forum.confluent.io/u/Archita)\
**Replies:** 7\
**Last updated:** [25 November 2025 10:48 UTC](https://forum.confluent.io/t/feasibility-of-using-confluent-cloud-schema-registry-with-gcp-managed-kafka/38182 "2025-11-25T10:48:25Z")

</div>

Hi Team, I’m exploring the possibility of integrating Confluent Cloud Schema Registry with an external Kafka cluster, specifically GCP Managed Kafka (Google Cloud Managed Kafka / Apache Kafka service). I went through t…

---

## [Confluent Cloud organization ID in Google Cloud](https://forum.confluent.io/t/confluent-cloud-organization-id-in-google-cloud/38176)

<div class="topic-metadata">

**Author:** [@alfredojury](https://forum.confluent.io/u/alfredojury)\
**Replies:** 2\
**Last updated:** [7 November 2025 16:02 UTC](https://forum.confluent.io/t/confluent-cloud-organization-id-in-google-cloud/38176 "2025-11-07T16:02:58Z")

</div>

Hi All, I’m setting up a vpc peering to connect our GCP project to our cluster in Confluent Cloud. As per the below Confluent documentation, I have to find out the Confluent Cloud org ID in Google Cloud in order to whit…

---

## [Is Control Centre available with confluent platform version 6.0.0v](https://forum.confluent.io/t/is-control-centre-available-with-confluent-platform-version-6-0-0v/38091)

<div class="topic-metadata">

**Author:** [@Jai-Pandey](https://forum.confluent.io/u/Jai-Pandey)\
**Replies:** 5\
**Last updated:** [27 August 2025 20:54 UTC](https://forum.confluent.io/t/is-control-centre-available-with-confluent-platform-version-6-0-0v/38091 "2025-08-27T20:54:07Z")

</div>

I am using confluent platform version 6.0.0 and it is not having control centre, can u please suggest what will be the possible reason and solution

---

## [Inconsistency between notifications and documentation regarding deprecated functions](https://forum.confluent.io/t/inconsistency-between-notifications-and-documentation-regarding-deprecated-functions/37987)

<div class="topic-metadata">

**Author:** [@chris\_eh](https://forum.confluent.io/u/chris_eh)\
**Replies:** 2\
**Last updated:** [29 July 2025 07:01 UTC](https://forum.confluent.io/t/inconsistency-between-notifications-and-documentation-regarding-deprecated-functions/37987 "2025-07-29T07:01:05Z")

</div>

Hello everyone, we are using confluent cloud with different type of clients. Since a few days, for one of our clients we get the message, that it is using deprecated functions and “deprecated clients will be removed fr…

---

## [RHEL-7 to RHEL8 Upgrade and Kafka 7.3 to 7.9 Upgrade](https://forum.confluent.io/t/rhel-7-to-rhel8-upgrade-and-kafka-7-3-to-7-9-upgrade/37995)

<div class="topic-metadata">

**Author:** [@pramod](https://forum.confluent.io/u/pramod)\
**Replies:** 0\
**Last updated:** [22 July 2025 05:44 UTC](https://forum.confluent.io/t/rhel-7-to-rhel8-upgrade-and-kafka-7-3-to-7-9-upgrade/37995 "2025-07-22T05:44:40Z")

</div>

We are planning to upgrade OS from Version- RHEL-7 to RHEL8 Upgrade in AWS and Application Kafka from Version- 7.3 to 7.9 Upgrade. Could you please check and suggest: Shall we install Kafka 7.3(Current version) → 7.5 …

---

## [Error while running kafka topic produce](https://forum.confluent.io/t/error-while-running-kafka-topic-produce/10890)

<div class="topic-metadata">

**Author:** [@anjum](https://forum.confluent.io/u/anjum)\
**Replies:** 5\
**Last updated:** [30 May 2025 22:14 UTC](https://forum.confluent.io/t/error-while-running-kafka-topic-produce/10890 "2025-05-30T22:14:16Z")

</div>

Hi, I am following this page to explore kafka. Confluent CLI Overview | Confluent Documentation I was able to create cluster and topic. Now I want to get something into the topic named “orders”. When I give the follow…

---

## [org.apache.kafka.common.errors.GroupAuthorizationException: Not authorized to access group: sample\_data\_orders](https://forum.confluent.io/t/org-apache-kafka-common-errors-groupauthorizationexception-not-authorized-to-access-group-sample-data-orders/37835)

<div class="topic-metadata">

**Author:** [@alberttwong](https://forum.confluent.io/u/alberttwong)\
**Replies:** 0\
**Last updated:** [26 May 2025 23:29 UTC](https://forum.confluent.io/t/org-apache-kafka-common-errors-groupauthorizationexception-not-authorized-to-access-group-sample-data-orders/37835 "2025-05-26T23:29:21Z")

</div>

I’m getting this error when using service accounts on the data gen “orders” connector. Failed to estimate payload bytes for kafka topic sample\_data\_orders org.apache.kafka.common.errors.GroupAuthorizationException: Not …

---

## [Integrate kafka 4 with jboss 7.4](https://forum.confluent.io/t/integrate-kafka-4-with-jboss-7-4/37758)

<div class="topic-metadata">

**Author:** [@indeed](https://forum.confluent.io/u/indeed)\
**Replies:** 0\
**Last updated:** [7 May 2025 08:56 UTC](https://forum.confluent.io/t/integrate-kafka-4-with-jboss-7-4/37758 "2025-05-07T08:56:31Z")

</div>

Hi I want to integrate kafka 4 with jboss 7.4 via resource adapter with consume MDB. need sample ra.xml that work with kafka 4 and jboss 7.4 i try this but not work: github.com /JFTechnology/jca-kafka/blob/a3c6338590…

---

## [How can you tell if the kafka message is transactional or not](https://forum.confluent.io/t/how-can-you-tell-if-the-kafka-message-is-transactional-or-not/37710)

<div class="topic-metadata">

**Author:** [@alberttwong](https://forum.confluent.io/u/alberttwong)\
**Replies:** 1\
**Last updated:** [29 April 2025 15:51 UTC](https://forum.confluent.io/t/how-can-you-tell-if-the-kafka-message-is-transactional-or-not/37710 "2025-04-29T15:51:41Z")

</div>

does it show in the metadata or somewhere?

---

## [What confluent cloud service account permissions do I need to access schema registry](https://forum.confluent.io/t/what-confluent-cloud-service-account-permissions-do-i-need-to-access-schema-registry/37704)

<div class="topic-metadata">

**Author:** [@alberttwong](https://forum.confluent.io/u/alberttwong)\
**Replies:** 3\
**Last updated:** [29 April 2025 18:44 UTC](https://forum.confluent.io/t/what-confluent-cloud-service-account-permissions-do-i-need-to-access-schema-registry/37704 "2025-04-29T18:44:11Z")

</div>

There are 2 types of api keys - my (user) account and service account. When I use user account which gives you all the permissions, I can see my schema associated to my topic. However when I use service account, I can…

---

## [Confluentinc/cp-kafka-connect:7.9.0 version compatibility issue](https://forum.confluent.io/t/confluentinc-cp-kafka-connect-7-9-0-version-compatibility-issue/37714)

<div class="topic-metadata">

**Author:** [@Smrutiranjan209](https://forum.confluent.io/u/Smrutiranjan209)\
**Replies:** 0\
**Last updated:** [29 April 2025 08:38 UTC](https://forum.confluent.io/t/confluentinc-cp-kafka-connect-7-9-0-version-compatibility-issue/37714 "2025-04-29T08:38:20Z")

</div>

Dear Confluent Community Support Team, Currently, we are doing version upgrade for apache camel salesforce kafka connector. We are upgrading confluentinc/cp-kafka-connect from 6.0.0 to 7.9.0 and camel-salesforce from 3…

---

## [Error: failed to read local ports from config](https://forum.confluent.io/t/error-failed-to-read-local-ports-from-config/37587)

<div class="topic-metadata">

**Author:** [@snehagupta](https://forum.confluent.io/u/snehagupta)\
**Replies:** 1\
**Last updated:** [27 March 2025 15:00 UTC](https://forum.confluent.io/t/error-failed-to-read-local-ports-from-config/37587 "2025-03-27T15:00:01Z")

</div>

Hi, I’m trying to create a topic in confluent local by running the command confluent local kafka topic create test-topic but I’m getting error saying that Error: failed to read local ports from config Suggestions: …

---

## [TimeoutException on Call: fetchMetadata](https://forum.confluent.io/t/timeoutexception-on-call-fetchmetadata/5835)

<div class="topic-metadata">

**Author:** [@stexxen](https://forum.confluent.io/u/stexxen)\
**Replies:** 3\
**Last updated:** [19 March 2025 10:06 UTC](https://forum.confluent.io/t/timeoutexception-on-call-fetchmetadata/5835 "2025-03-19T10:06:01Z")

</div>

Hi, I’m pretty sure my problem is related to permissions as it doesn’t happen when connecting to a local Dev instance of Kafka. Using Confluent Cloud, everything (reading+writing) is working, but I see the following er…

---

## [Unable to consume message from topic getting error as GROUP\_AUTHORIZATION\_FAILED](https://forum.confluent.io/t/unable-to-consume-message-from-topic-getting-error-as-group-authorization-failed/5826)

<div class="topic-metadata">

**Author:** [@rameshshivakumar](https://forum.confluent.io/u/rameshshivakumar)\
**Replies:** 4\
**Last updated:** [3 March 2025 15:05 UTC](https://forum.confluent.io/t/unable-to-consume-message-from-topic-getting-error-as-group-authorization-failed/5826 "2025-03-03T15:05:03Z")

</div>

Hello Team my confluent kafka cluster is configured in cloud . when i am trying to connect with below details ‘bootstrap.servers’: “cluster bootstapserver”, ‘sasl.mechanisms’: PLAIN, ‘security.protocol’: SASL\_SSL ‘s…

---

## [Confluent Control Center Shows Black Screen – How to Fix?](https://forum.confluent.io/t/confluent-control-center-shows-black-screen-how-to-fix/37369)

<div class="topic-metadata">

**Author:** [@xirawa](https://forum.confluent.io/u/xirawa)\
**Replies:** 1\
**Last updated:** [28 February 2025 11:51 UTC](https://forum.confluent.io/t/confluent-control-center-shows-black-screen-how-to-fix/37369 "2025-02-28T11:51:22Z")

</div>

Hi everyone, Iam experiencing a black screen issue when trying to access Confluent Control Center. The page loads, but instead of displaying the UI, it remains completely black. I have tried different browsers and devic…

---

## [Black Screen Issue in Confluent Control Center – UI Not Loading](https://forum.confluent.io/t/black-screen-issue-in-confluent-control-center-ui-not-loading/37350)

<div class="topic-metadata">

**Author:** [@cowem](https://forum.confluent.io/u/cowem)\
**Replies:** 1\
**Last updated:** [27 February 2025 11:56 UTC](https://forum.confluent.io/t/black-screen-issue-in-confluent-control-center-ui-not-loading/37350 "2025-02-27T11:56:09Z")

</div>

Hi Everyone, I recently installed Confluent Platform and started Confluent Control Center to monitor my Kafka clusters, but when I open the UI in my browser, all I see is a black screen with no content. Everything else…

---

## [ERROR Could not instantiate class \[net.logstash.log4j.JSONEventLayoutV1\]](https://forum.confluent.io/t/error-could-not-instantiate-class-net-logstash-log4j-jsoneventlayoutv1/37352)

<div class="topic-metadata">

**Author:** [@sanjay0816](https://forum.confluent.io/u/sanjay0816)\
**Replies:** 0\
**Last updated:** [27 February 2025 17:52 UTC](https://forum.confluent.io/t/error-could-not-instantiate-class-net-logstash-log4j-jsoneventlayoutv1/37352 "2025-02-27T17:52:43Z")

</div>

I have upgraded confluent kafka from 6.2 to 7.0.16 using below docker file and getting below error ===\> Check if Zookeeper is healthy ... SLF4J: Class path contains multiple SLF4J bindings. SLF4J: Found binding in \[jar:…

---

## [Rate Limited when producing message to my cluster](https://forum.confluent.io/t/rate-limited-when-producing-message-to-my-cluster/37275)

<div class="topic-metadata">

**Author:** [@jerryhu](https://forum.confluent.io/u/jerryhu)\
**Replies:** 2\
**Last updated:** [19 February 2025 18:31 UTC](https://forum.confluent.io/t/rate-limited-when-producing-message-to-my-cluster/37275 "2025-02-19T18:31:12Z")

</div>

Hey folks, I’m using Rest Endpoint to produce kafka message to my topic in my cluster. However, I recently hit a 429 too many requests error. I was not aware my cluster has a rate limit. Is there a way to increase the …

---

## [Issues Adding ACLs in KRaft Mode Kafka Cluster - No Authorizer Configured Error](https://forum.confluent.io/t/issues-adding-acls-in-kraft-mode-kafka-cluster-no-authorizer-configured-error/37238)

<div class="topic-metadata">

**Author:** [@sgangu](https://forum.confluent.io/u/sgangu)\
**Replies:** 3\
**Last updated:** [18 February 2025 05:58 UTC](https://forum.confluent.io/t/issues-adding-acls-in-kraft-mode-kafka-cluster-no-authorizer-configured-error/37238 "2025-02-18T05:58:52Z")

</div>

Hi everyone, I’m encountering an issue while working with a KRaft-mode Kafka cluster. I can list ACLs without any issues, but when I try to add a new ACL, I get the following error: Error while executing ACL command: o…

---

## [Cdc Debezium connector](https://forum.confluent.io/t/cdc-debezium-connector/37244)

<div class="topic-metadata">

**Author:** [@dhruvilp](https://forum.confluent.io/u/dhruvilp)\
**Replies:** 1\
**Last updated:** [17 February 2025 11:50 UTC](https://forum.confluent.io/t/cdc-debezium-connector/37244 "2025-02-17T11:50:46Z")

</div>

Hi Team, We are trying to process approx. 7Million records in a table. We are getting Lock request time out period exceeded. While the initial snapshot getting the below error: Before the error here are the configs w…

---

## [Ingress IP Whitelisting for Confluent Cloud public internet clusters](https://forum.confluent.io/t/ingress-ip-whitelisting-for-confluent-cloud-public-internet-clusters/7438)

<div class="topic-metadata">

**Author:** [@chuck-alt-delete](https://forum.confluent.io/u/chuck-alt-delete)\
**Replies:** 4\
**Last updated:** [7 February 2025 20:47 UTC](https://forum.confluent.io/t/ingress-ip-whitelisting-for-confluent-cloud-public-internet-clusters/7438 "2025-02-07T20:47:30Z")

</div>

Is it currently possible to restrict the source IPs that are allowed to access my confluent cloud cluster that uses public internet networking?

---

## [Active Connections Count in Confluent Cloud](https://forum.confluent.io/t/active-connections-count-in-confluent-cloud/5582)

<div class="topic-metadata">

**Author:** [@sap1ens](https://forum.confluent.io/u/sap1ens)\
**Replies:** 3\
**Last updated:** [7 February 2025 11:15 UTC](https://forum.confluent.io/t/active-connections-count-in-confluent-cloud/5582 "2025-02-07T11:15:57Z")

</div>

Hey everyone, I started using a Standard Kafka cluster and was surprised by how fast the number of active connections can grow. I started investigating why: Every Kafka consumer and producer needs to connect to a lead…

[Next page](https://forum.confluent.io/c/confluent-cloud/5.md?page=1)
