# Confluent SchemaRegistry throwing io.confluent.kafka.schemaregistry.rest.exceptions.RestUnknownLeaderException: Leader not known Error

**URL:** https://forum.confluent.io/t/confluent-schemaregistry-throwing-io-confluent-kafka-schemaregistry-rest-exceptions-restunknownleaderexception-leader-not-known-error/7166
**Category:** Schema Registry
**Created:** [6 February 2023 08:01 UTC](https://forum.confluent.io/t/confluent-schemaregistry-throwing-io-confluent-kafka-schemaregistry-rest-exceptions-restunknownleaderexception-leader-not-known-error/7166 "2023-02-06T08:01:51Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![keyurbitw](https://avatars.discourse-cdn.com/v4/letter/k/e36b37/32.png) [@keyurbitw](https://forum.confluent.io/u/keyurbitw)
#### Post date: [6 February 2023 08:01 UTC](https://forum.confluent.io/t/confluent-schemaregistry-throwing-io-confluent-kafka-schemaregistry-rest-exceptions-restunknownleaderexception-leader-not-known-error/7166/1 "2023-02-06T08:01:51Z")

</div>

Hi, We have been using Schema Registry in HA mode with 3 replicas. We have started seeing

> io.confluent.kafka.schemaregistry.rest.exceptions.RestUnknownLeaderException: Leader not known.

error intermittently. We have made leader.eligibility=true in the configuration.

All the 3 pods are running behind a ClusterIp-type service in a k8s cluster. We don’t see any other major error logs in the pods so it’s kind of hard to find the issue. Can you please help us if finding out the root cause of this?

---

<div class="post-metadata">

### Author: ![relaxomatic](https://avatars.discourse-cdn.com/v4/letter/r/e9a140/32.png) [@relaxomatic](https://forum.confluent.io/u/relaxomatic)
#### Post date: [7 February 2023 05:41 UTC](https://forum.confluent.io/t/confluent-schemaregistry-throwing-io-confluent-kafka-schemaregistry-rest-exceptions-restunknownleaderexception-leader-not-known-error/7166/2 "2023-02-07T05:41:17Z")

</div>

I beleive it’s because they cannot communicate to each other and you need to set the advertised host name to the pod if when deployed.  
Using Confluent’s container image I set

```auto
            - name: CONNECT_REST_ADVERTISED_HOST_NAME
              valueFrom:
                fieldRef:
                  fieldPath: status.podIP

```

to achieve this.

---

<div class="post-metadata">

### Author: ![anton-jc](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/anton-jc/32/3331_2.png) [@anton-jc](https://forum.confluent.io/u/anton-jc)
#### Post date: [10 November 2023 02:48 UTC](https://forum.confluent.io/t/confluent-schemaregistry-throwing-io-confluent-kafka-schemaregistry-rest-exceptions-restunknownleaderexception-leader-not-known-error/7166/3 "2023-11-10T02:48:42Z")

</div>

Is the problem solved? I had the same problem. We have been using Schema Registry in HA mode with 3 replicas. and used kafkastore.bootstrap.servers config to connect the kafka
