Consuming with JMS Connectors causing format issues

Hello all, i want to get some suggestions for the below issue.
We are using JMS connectors in kafka for transferring messages and using avro format for serializing messages. The issue here is , we are posting an XML message in source connector but while receiving we are getting it as JSON format with headers.
Is there any other option to serialize message format to get XML message as it is from the consumer?
PFB - Posted and received message

Posted :

<Root>
<Child>
<Hello>hello</Hello>
</Child>
</Root>

Received :

{"messageID":"ID:<755895.1644562443183.0>","messageType":"text","timestamp":1644562443183,"deliveryMode":2,"correlationID":null,"replyTo":null,"destination":{"destinationType":"topic","name":"com.bt.jms.module.orb2b.apb2bod1!bt.jms.topic.test1"},"redelivered":false,"type":null,"expiration":0,"priority":4,"properties":{"JMSXDeliveryCount":{"propertyType":"integer","boolean":null,"byte":null,"short":null,"integer":1,"long":null,"float":null,"double":null,"string":null,"bytes":null}},"bytes":null,"map":null,"text":"<Root>
<Child>
<Hello>hello</Hello>
</Child>
</Root>"}

Kindly help us with this issue.

Hi @Shahul_Hameed .
@Kameshwaran just posted the exact same request at Unable to serialize XML format in JMS Sink Connect - #2 by vnadkarni. Iā€™m guessing you two work together :slight_smile:

People can reply on the other thread at:
https://forum.confluent.io/t/unable-to-serialize-xml-format-in-jms-sink-connect/4175/2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.