# Java Heap Space Error

**URL:** <https://forum.confluent.io/t/java-heap-space-error/7030>\
**Category:** Clients\
**Created:** [17 January 2023 08:37 UTC](https://forum.confluent.io/t/java-heap-space-error/7030 "2023-01-17T08:37:40Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![hasmine.roldan](https://avatars.discourse-cdn.com/v4/letter/h/8e8cbc/32.png) [@hasmine.roldan](https://forum.confluent.io/u/hasmine.roldan)\
**Post date:** [17 January 2023 08:37 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/1 "2023-01-17T08:37:40Z")

</div>

Hi,

Good day!

I encountered an error below while creating a topic.

NOTE: zookeeper and kafka are SSL enabled

```auto
[rhel@kafkanode1 bin]$ /home/rhel/confluent-6.0.5/bin/kafka-topics --bootstrap-server kafkanode1.localdomain:9092 \
> --create \
> --topic test1 \
> --partitions 1 \
> --replication-factor 1
[2023-01-17 16:35:30,354] ERROR Uncaught exception in thread 'kafka-admin-client-thread | adminclient-1': (org.apache.kafka.common.utils.KafkaThread)
java.lang.OutOfMemoryError: Java heap space
        at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:57)
        at java.nio.ByteBuffer.allocate(ByteBuffer.java:335)
        at org.apache.kafka.common.memory.MemoryPool$1.tryAllocate(MemoryPool.java:30)
        at org.apache.kafka.common.network.NetworkReceive.readFrom(NetworkReceive.java:113)
        at org.apache.kafka.common.network.KafkaChannel.receive(KafkaChannel.java:447)
        at org.apache.kafka.common.network.KafkaChannel.read(KafkaChannel.java:397)
        at org.apache.kafka.common.network.Selector.attemptRead(Selector.java:678)
        at org.apache.kafka.common.network.Selector.pollSelectionKeys(Selector.java:580)
        at org.apache.kafka.common.network.Selector.poll(Selector.java:485)
        at org.apache.kafka.clients.NetworkClient.poll(NetworkClient.java:547)
        at org.apache.kafka.clients.admin.KafkaAdminClient$AdminClientRunnable.processRequests(KafkaAdminClient.java:1293)
        at org.apache.kafka.clients.admin.KafkaAdminClient$AdminClientRunnable.run(KafkaAdminClient.java:1224)
        at java.lang.Thread.run(Thread.java:750)
Error while executing topic command : Call(callName=createTopics, deadlineMs=1673944590067, tries=1, nextAllowedTryMs=-9223372036854775709) timed out at 9223372036854775807 after 1 attempt(s)
[2023-01-17 16:35:30,360] ERROR org.apache.kafka.common.errors.TimeoutException: Call(callName=createTopics, deadlineMs=1673944590067, tries=1, nextAllowedTryMs=-9223372036854775709) timed out at 9223372036854775807 after 1 attempt(s)
Caused by: org.apache.kafka.common.errors.TimeoutException: The AdminClient thread has exited.
 (kafka.admin.TopicCommand$)

```

---

<div class="post-metadata">

**Author:** ![daveklein](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/daveklein/32/140_2.png) [@daveklein](https://forum.confluent.io/u/daveklein)\
**Post date:** [17 January 2023 22:27 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/2 "2023-01-17T22:27:08Z")

</div>

Could it actually be a memory issue? Are you running in a VM with low memory allocated? Perhaps you can give a bit more info about your environment. Just not a lot to go on with that stacktrace.

---

<div class="post-metadata">

**Author:** ![hasmine.roldan](https://avatars.discourse-cdn.com/v4/letter/h/8e8cbc/32.png) [@hasmine.roldan](https://forum.confluent.io/u/hasmine.roldan)\
**Post date:** [18 January 2023 08:11 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/3 "2023-01-18T08:11:06Z")

</div>

Hi, it is running on VM. Tried creating a topic before without SSL and it worked. However, upon enabling the SSL I encountered this error.

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [18 January 2023 12:42 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/4 "2023-01-18T12:42:38Z")

</div>

looks like a known error when ssl is not properly configured on client side  
on which port does your cluster listen for ssl connections?

basically I would recommend to follow this doc:  
[https://docs.confluent.io/platform/current/kafka/encryption.html#encrypt-with-tls](https://docs.confluent.io/platform/current/kafka/encryption.html#encrypt-with-tls)

best,  
michael

---

<div class="post-metadata">

**Author:** ![arunmgundagadagi](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/arunmgundagadagi/32/4012_2.png) [@arunmgundagadagi](https://forum.confluent.io/u/arunmgundagadagi)\
**Post date:** [23 September 2024 12:36 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/5 "2024-09-23T12:36:08Z")

</div>

I am also getting same error when I run kafka in non secure port 9092 that topics are creating but when I tried to create topcs using secure port 9093 using SSL the below error is occuring ??? why I am stucked here …And I ensure that there server props and client side props are correctly cnfigered

kafka-topics --create --bootstrap-server localhost:9093 --topic sasl-test1 --partitions 2 --replication-factor 1  
[2024-09-23 18:01:14,099] ERROR Uncaught exception in thread ‘kafka-admin-client-thread | adminclient-1’: (org.apache.kafka.common.utils.KafkaThread)  
java.lang.OutOfMemoryError: Java heap space

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [23 September 2024 12:47 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/6 "2024-09-23T12:47:45Z")

</div>

woudl you mind sharing your client.properties?

---

<div class="post-metadata">

**Author:** ![arunmgundagadagi](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/arunmgundagadagi/32/4012_2.png) [@arunmgundagadagi](https://forum.confluent.io/u/arunmgundagadagi)\
**Post date:** [23 September 2024 14:22 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/7 "2024-09-23T14:22:08Z")

</div>

security.protocol=SSL  
ssl.truststore.location=/var/private/ssl/client.truststore.jks  
ssl.truststore.password=allkeys

ssl.keystore.location=/var/private/ssl/client.keystore.jks  
ssl.keystore.password=allkeys  
ssl.key.password=allkeys

this is my client-ssl.properties and I am also running in VM

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [24 September 2024 08:30 UTC](https://forum.confluent.io/t/java-heap-space-error/7030/8 "2024-09-24T08:30:34Z")

</div>

ok  
looks valid so far.

any error in broker logs?  
best,  
michael
