# Tutorial: Introduction to Streaming is Broken

**URL:** <https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362>\
**Category:** Certification and Training\
**Created:** [22 June 2022 14:03 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362 "2022-06-22T14:03:56Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![OkkerBotes](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/okkerbotes/32/1993_2.png) [@OkkerBotes](https://forum.confluent.io/u/OkkerBotes)\
**Post date:** [22 June 2022 14:03 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/1 "2022-06-22T14:03:56Z")

</div>

Hi, I am unable to run the configuration script for the Tut published here.  
[https://docs.confluent.io/platform/current/tutorials/examples/microservices-orders/docs/index.html#additional-resources](https://docs.confluent.io/platform/current/tutorials/examples/microservices-orders/docs/index.html#additional-resources)

I running Windows 11 with the Bash command line.

My first set of errors is on “Creating demo topics”

" on Confluent Cloudze  
Error: REST request failed: Internal Server Error (500)

on Confluent Cloudomers  
Error: REST request failed: Internal Server Error (500)

on Confluent Cloud  
Error: REST request failed: Internal Server Error (500)

on Confluent Cloudrs  
Error: REST request failed: Internal Server Error (500)

on Confluent Cloudrs-enriched  
Error: REST request failed: Internal Server Error (500)

on Confluent Cloudr-validations  
Error: REST request failed: Internal Server Error (500)  
… and so on"

Any help would be much appreciated.

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [22 June 2022 14:10 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/2 "2022-06-22T14:10:13Z")

</div>

Hi @OkkerBotes

welcome 🙂

which script is causing the issue?  
could provide some info which step we are talking about?

best,  
michael

---

<div class="post-metadata">

**Author:** ![OkkerBotes](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/okkerbotes/32/1993_2.png) [@OkkerBotes](https://forum.confluent.io/u/OkkerBotes)\
**Post date:** [22 June 2022 14:27 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/3 "2022-06-22T14:27:35Z")

</div>

Hi Michael and thanks for the repaly.

It is the “./start-ccloud.sh” script that is run as part of step two of the Tud. I can see on the confluent portal that the Environment “ccloud-stack-sa-8wwk35-microservices-orders” get created but there are no topics.

Okkie  
ps. I have to run now so will have to catch you later.

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [22 June 2022 14:44 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/4 "2022-06-22T14:44:48Z")

</div>

hmm ok I see  
need to try it by myself

maybe it’s related to bash on windows

> [@OkkerBotes](#):
>
> on Confluent Cloudrs

looks strange

need to check on my local linux box; probably tomorrow morning 😉

best,  
michael

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [23 June 2022 05:04 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/5 "2022-06-23T05:04:57Z")

</div>

hi @OkkerBotes

just to debug a little deeper.  
could you try to run the schema creation manually?  
script is located in

`./scripts/create-topics-ccloud.sh ./topics.txt`

best,  
michael

---

<div class="post-metadata">

**Author:** ![OkkerBotes](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/okkerbotes/32/1993_2.png) [@OkkerBotes](https://forum.confluent.io/u/OkkerBotes)\
**Post date:** [23 June 2022 07:21 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/6 "2022-06-23T07:21:32Z")

</div>

Hi @mmuehlbeyer

Thanks again for your assistance. I have run the scrip but looks like it need a context.

"$ ./scripts/create-topics-ccloud.sh ./topics.txt  
Error: no Kafka cluster selected

Suggestions:  
You must pass `--cluster` or `--resource` with the command or set an active Kafka cluster in your context with `confluent kafka cluster use`.  
./scripts/create-topics-ccloud.sh: line 14: [: -eq: unary operator expected  
"

I have to focus on something else today so will come back to this on Monday.

Okkie

---

<div class="post-metadata">

**Author:** ![mmuehlbeyer](https://sea1.discourse-cdn.com/flex019/user_avatar/forum.confluent.io/mmuehlbeyer/32/1088_2.png) [@mmuehlbeyer](https://forum.confluent.io/u/mmuehlbeyer)\
**Post date:** [23 June 2022 07:32 UTC](https://forum.confluent.io/t/tutorial-introduction-to-streaming-is-broken/5362/7 "2022-06-23T07:32:54Z")

</div>

ah yes I see

if I have some time left today or tomorrow I’ll try to  
run the demo on Linux and post my result here

best,  
michael
