Cp-kafka installation on kubernetes

Hello Team,

I am deploying kafka containers (zookeeper , kafka , kafka-connect ) on kubernetes using helm chart. I am using the charts from confluent’s github repo. I have a Azure devops pipeline to run the charts.

Container images are stored in Azure container registry.

As first step , deploying the zookeeper , the pod gets deployed but is failing to fetch the image from registry. I see below error in the pod

Warning InspectFailed 4m1s (x538 over 119m) kubelet Failed to apply default image tag "map[pullPolicy:IfNotPresent ]:": couldn't parse image reference "map[pullPolicy:IfNotPresent repository:*********]:": invalid reference format

image details are defined as below in values.yaml

  repository: acrname/cp-zookeeper
  pullPolicy: IfNotPresent
  tag: 7.0.1

i have tried passing the repo and image details in pipeline through chart arguments but doesnt pull it either.

Would confluent helm charts needs to be updated before can be used ?

Appreciate if i can get some insights on it.

hi @Shahed

could you provide some more insights?
my understanding is:
you pushed the cp-zookeeper image to azure container registry and now try to run the confluent provided helm chart with some adoptions, correct?

how did you start install and start the helm chart?


That’s correct Michael.
I have cloned the confluent charts and added them to my github repo . I provide the chart parth to helm deploy function/step in devops pipeline.

not sure whether the image tag is set correctly
did you try with
imageTag: 7.0.1


I have tried it but doesn’t work. Will check if its due to helm version that is causing the issue.