Facing issue using ENUM

I have one field ‘statusCode’ in my schema with dataType as ENUM.
When I am trying to publish the event I’m getting “Caused by: org.apache.avro.AvroTypeException: Not an enum: S for schema”.
I tried by casting dataType into enum in select query but got invalid datatype for it in Oracle. Using transforms also no luck, I can’t use custom transformers in my application, Also don’t have access to change the schema.
I am using value.converter as Avro & key.converter as String
Is there any way achieve this?

What connector are you using? JdbcSourceConnector? Could you please share more details on the Oracle DDL and connector configuration? What do you mean when you say “When I am trying to publish the event”? Do you mean when you add a row to the table in Oracle?

Yes, I am using kafka JDBC source connector.
I have one event/data in oracle table with 3 fields/columns in it.
ie AcctKey, statusCode & EventTopic.
Datatype of statusCode is enum( values {S, R})
Using source connector I am trying to publish that event/data from oracle table & I am also using Kafka jdbc sink connector to consume same event/data in postgres Table. But dataType enum is not supporting.

Try setting value.converter.enhanced.avro.schema.support=true. From the docs:

When set to true , this property preserves Avro schema package information and Enums when going from Avro schema to Connect schema. This information is added back in when going from Connect schema to Avro schema.

Hi Dave, Thanks!
I tried by setting property “value.converter.enhanced.avro.schema.support”: “true” in my source connector config, but no luck :frowning: Still getting same exception

I have the same issue. Have you been able to find a solution ?
The property “value.converter.enhanced.avro.schema.support”: “true” also doesn’t work for me.