KRaft and AclAuthorizer

Hi, I would like to enable AclAuthorizer on a KRaft cluster but I receive this error:

ERROR [ControllerServer id=2] Fatal error during controller startup. Prepare to shutdown (kafka.server.ControllerServer)
at kafka.zk.KafkaZkClient$.apply(KafkaZkClient.scala:1965)
at kafka.server.ControllerServer.$anonfun$startup$11(ControllerServer.scala:118)
at kafka.server.ControllerServer.$anonfun$startup$11$adapted(ControllerServer.scala:118)
at scala.Option.foreach(Option.scala:437)
at kafka.server.ControllerServer.startup(ControllerServer.scala:118)
at kafka.server.KafkaRaftServer.$anonfun$startup$1(KafkaRaftServer.scala:109)
at kafka.server.KafkaRaftServer.$anonfun$startup$1$adapted(KafkaRaftServer.scala:109)
at scala.Option.foreach(Option.scala:437)
at kafka.server.KafkaRaftServer.startup(KafkaRaftServer.scala:109)
at kafka.Kafka$.main(Kafka.scala:109)
at kafka.Kafka.main(Kafka.scala)6b3

It seems I need to specify a zookeeper url but I do not have it as I’m using KRaft.

How should I configure the AclAuthorizer in this situation?

Hi @webfrank, welcome to the forum :slight_smile:
Can you detail what version of Kafka you’re using, and what steps you’re taking to enable AclAuthorization?

@webfrank To use the AclAuthorizer with Kraft mode, you’ll still need a ZK cluster and you’ll configure it as normal. Please note this Jira related to a new Kraft Authorizer which has been merged into the 3.2 branch [KAFKA-13646] Implement KIP-801: KRaft authorizer - ASF JIRA

1 Like