More than two connectors

Hi, I am trying to create more than two connectors but I got an error saying “No suitable driver found for jdbc:oracle:thin:@”.

The first two connectors are runningpropertly, but I cannot create more than two.

$ curl http://XXXX:8083/connectors/jdbc_sink_oracle_ctc/status


$ curl http://XXX:8083/connectors/jdbc_sink_oracle_ctc/status


Can you help me on that?

Do you have more than one Kafka Connect worker in your cluster? Have you installed the JDBC driver across all of them?

I am a beginner with Kafka, so I don’t know exactly how many workers are running.
How can I see that?

But, I have installed 3 brokers and I installed JDBC across all of them.

systemctl status confluent-kafka-connect
● confluent-kafka-connect.service - Apache Kafka Connect - distributed
   Loaded: loaded (/usr/lib/systemd/system/confluent-kafka-connect.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2022-03-23 19:40:48 EDT; 3 days ago
 Main PID: 22329 (java)
    Tasks: 53
   Memory: 1.6G
   CGroup: /system.slice/confluent-kafka-connect.service
           └─22329 java -Xms256M -Xmx2G -server -XX:+UseG1GC -XX:MaxGCPauseMillis=20 -XX:InitiatingHeapOccupancyPercent=35 -XX:...

That’s my kafka-connect properties config in one of the brokers




Have you install both the JDBC connector and the JDBC driver across all of them?

No suitable driver found for jdbc:oracle:thin leads me to think that the JDBC driver is missing.

1 Like

The Driver is across all of them.
I restart all kafka services and I could create 3 connectors.

What Do I need to do to create 10 connectors?

Thank you very much

If it’s all working and you’ve created 3, you can just go ahead and create as many as you need. Kafka Connect will balance the load across the available workers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.