Open Telemetry Kafka Exporter with Confluent Cloud

Dear Community,

Did anyone already tried opentelemetry-collector-contrib/exporter/kafkaexporter at main · open-telemetry/opentelemetry-collector-contrib · GitHub with Confluent Cloud?

We manged to get this working with Apache Kafka but does not work with Confluent Cloud below SASL configs but does not work.

Appreciate your guidance if someone did this already

    - ***-*****.**-**-*
    protocol_version: 2.0.0
        username: ***********
        password: ***********************************
        mechanism: PLAIN


This works for me :slight_smile:

    protocol_version: 2.0.0
    brokers: * 
        username: "[Redacted]"
        password: "[Redacted]"
        mechanism: "PLAIN"
        insecure: false
        insecure_skip_verify: true

Let me know if it helps,



Thakn you very much for your response. I was able to connect to the broker with the above configurations last night but I keep getting the below error from the collector. Were you able to send spans/metrics/logs to the topics?

fka", “error”: “Failed to deliver 1 messages due to circuit breaker is open”, “interval”: “18.939500188s”}
2022-09-01T17:34:08.119Z info exporterhelper/queued_retry.go:215 Exporting failed. Will retry the request after interval. {“kind”: “exporter”, “name”: “kafka”, “error”: “Failed to deliver 1 messages due to circuit breaker is open”, “interval”: “12.435480141s”}

No issues and metrics, spans and logs are all received.

How have you configured the pipelines ? Are the same messages received by other exporters in the same pipelines?

1 Like


Yes, configured the pipelines. Other exporters like kafka, logging, zipkin, jaeger received the data fine. Below is my pipeline.

  extensions: [pprof, zpages, health_check]
      receivers: [otlp]
      processors: [batch]
      exporters: [kafka, logging, zipkin, jaeger]
      receivers: [otlp]
      processors: [batch]
      exporters: [kafka, logging]

Seems the configurations are okay. Did the topics auto-create ? Have they been created in Confluent Cloud?

As you said this works with Apache Kafka, could it be something between your Otelcol and Confluent Cloud ? Think the issue would probably be better raised as an issue on the OpenTelemetry Github issue pages for more insight into that specific error message.

We created the topics manually and assigned the permissions for the service account used. I am guessing its related to permissions.
I will update here once we get it working.

Once again, thanks for the reply.

I think also… remove the topics and permissions and restart otelcol, then see which issues arise.

1 Like


Thanks for helping after fixing the typos in the service account and permissions it worked like a charm. This is now resolved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.