Trying to use java 17 and got an error

Hi guys!

Please, I’m trying to use java17 to run my ksqldb cluster, but when I try to start the service I receive the error: ksql-server-start: Unrecognized VM option UseConcMarkSweepGC

Using java 1.8.2 or 11 starts fine. I haven’t found any constraints about using java 17 in Confluent doc.


Hi @viniciusfmc,

Thank you for reporting this!

There’s a note about Java 8/11 support on here. In looking at, I’m thinking that it should also go here at least – is this the docs page you were looking at?


1 Like

Hi Dave!!

Thank you very much! Our cluster is fully operational using java 11. I was looking for higher performance from java 17 :smile: , but as you sent is a no go for now! Sorry for my blindness reading the doc hehehe!

Best Regards,
Vinícius Camargos

You could override the JVM options to remove/change the GC settings

Hi OneCricketeer!!

I did the test on our dev cluster. Editing ksql-run-class and removing ** -XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -XX:+CMSScavengeBeforeRemark** from KSQL_JVM_PERFORMANCE_OPTS worked flawlessly with java 17. But we are not confortable configuring our production cluster using anything but the Confluent doc recommendations. It’s important to Confluent update the ksqldb sw or the documentation (if it is not a problem using java 17) to support java 17. Even java 11 is getting dated.

Thanks for your comment!

Vinícius Camargos

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.