How to connect kafka-topics to brokers

Kafka version

kafka % ./bin/ --bootstrap-server localhost:9092 --version
3.4.0 (Commit:2e1947d240607d53)

Command i used to connect to broker which has ssl enabled
kafka % ./bin/ --bootstrap-server localhost:9090 --list

Error logs on broker:

INFO [SocketServer listenerType=ZK_BROKER, nodeId=0] Failed authentication with /localhost (channelId=localhost9090-localhost:49548-0) (SSL handshake failed) (

do i have to keep a diffrent listener which will accept clients with plaintext ? i didn’t found anything whether the kafka-topics ssl in implemented or not i am just new in kafka , i only know that previously it used to connect with zookeeper


In the second command, you use localhost:9090 vs localhost:9092
The default port for Kafka is 9092.

yes, i know , but i have configured server properties with sasl_ssl

my :


and when i try to connect with PLAINTEXT PORT i get :

> .\bin\windows\kafka-topics.bat --bootstrap-server localhost:9093  --list
Error while executing topic command : Timed out waiting for a node assignment. Call: listTopics
[2023-04-15 18:26:27,625] ERROR org.apache.kafka.common.errors.TimeoutException: Timed out waiting for a node assignment. Call: listTopics

is there any ssl security yet in kafka-topics ? i didnt found any docs, article related kafka-topics security

Yes. use --command-config flag and provide SSL/SASL properties with a file.