Kafka upgrade from 6.2.2 to 7.4.4

hello team,

i am upgrading the kafka 6.2.2 with zookeeper to 7.4.4 with 3 brokers as a standalone binaries.
kafka and zookeeper is started with new binaries but when i am trying to connect with the brokers via command line is getting failed with ssl handshake failures .

SocketServer listenerType=ZK_BROKER, nodeId=2] Failed authentication with /x.x.x.149 (channelId=x.x.x.149:9093-x.x.x.149:37416-115) (SSL handshake failed) (org.apache.kafka.common.network.Selector).

even when i tried individually kafka-server-start its started the process but when i run with the kafka-topics its giving me below errors.

/tsmage/confluent-7.4.4/bin/kafka-topics --bootstrap-server x014a.vsi.uat.abc.com:9093,x015a.vsi.uat.abc.com:9093,x016a.vsi.uat.abc.com:9093 --describe --topic csec
Error while executing topic command : Timed out waiting for a node assignment. Call: listTopics
[2024-03-15 15:13:53,957] ERROR org.apache.kafka.common.errors.TimeoutException: Timed out waiting for a node assignment. Call: listTopics

pl help me here.

thanks in advance.

even i have downgraded the cluster with 7.4.4 and i found the same issue, internally kafka is unable to connect any broker nodes.
anyone can suggest here.
note- my earlier versions 6.2.2 with the server.properties and zookeeper.properties and SSL are same i am using for this versions as well.