Kafka connect rebalance failed

I have 2 Kafka connect worker nodes. I have deployed Debezium connectors.

2 different connectors I deployed. Node 1 was managing connector 1 and node2 was managing connector 2.

I tried to restart the worker service on Node2.

As per the distributed mode, the connector-2’s tasks should move to the Node1. It worked. Then after a few seconds, I did the restart again, this time the rebalancing does not happen. Instead, the tasks went to a UNASSIGNED state. Exactly after 5mins from the worker service restart, its back to ASSIGNED state on the same node.

Then tried do restart the worker service for a couple of times, but no luck, Can someone help me what happened here and why the rebalanceing is not working?

I tried to restart, but its not solving my issue.

curl -X POST

{"error_code":409,"message":"Cannot complete request momentarily due to no known leader URL, likely because a rebalance was underway."}

Found the cause and the detailed information is here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.