Keep getting failed to validate Schema Registry API credential

I’m following the basic tutorial for Schema Registry here: Confluent Cloud.

I’m now trying to complete the final part of the tutorial:

However, in Step 4. Produce a message using your schema (replace <PATH_TO_SCHEMA_FILE> with your local path to the schema file), when I try to run it in the terminal, I keep getting the error message, “failed to validate Schema Registry API credential”

I’m at a loss as to what could be causing this because I haven’t encountered any problems in the tutorial so far until I got to this step.

Ooof, that’s no good. Can you please confirm the output to:

confluent api-key list 

Please verify that the Resource Type for one of the keys is schema-registry.

1 Like

Hi, Danica! Thanks for responding to my question. :blush: I have managed to fix the problem by re-enabling the Stream Governance Package but this time setting the region to Singapore (same as my cluster).

I don’t know for sure yet if this is what really fixed the issue or if I just mixed something up in my terminal. I’ll post an update on this thread once I know for sure. :blush: If you have thoughts or suggestions based on what I said above, I’m all ears as well. :blush:

1 Like