KSQL listener does not open any ports

We have a full Confluent Platform (5.3.1) setup, including KSQL, where all the components appear to be working just fine. However, when trying to troubleshoot KSQL configuration, I wanted to use the KSQL CLI. The problem is, I cannot connect to it, nor can I find any trace of it actually having opened any listening ports at all. No matter what I set in the configuration file, nothing changes. I cannot connect to the default (8088) port nor our custom one. I’ve tried commenting out the “listeners” directive altogether, no change.

I can see with “ss -tunlp” that the process does have ports open, including a JMX Prometheus exporter plugin we’ve loaded, but the only other port seems to be a dynamic one (changes every time I restart the process). No matter what I do or change, I cannot make the KSQL service register a listening port in the OS, or make it respond to any port when I connect to it.

There are no conflicting services either, all our other services on the server register their ports as expected and they are connectable. There is nothing in the logs, neither that it tries to open a listening port, nor that it would fail.

Are there any other steps to take to configure or troubleshoot this? Is there something special about how KSQL opens listener interfaces?

Since I cannot edit: I had missed the part about the ‘ksql.queries.file’ option disabling the CLI listener interface. This was the problem. I commented out this part and was immediately able to connect to the listener interface via the CLI tool.


Welcome to the forum, @maek48 !

Glad you were able to resolve the problem! :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.