Errors when starting S3 Connector

Hi team,

I am learning on Confluent Cloud and have created a topic and an S3 Connector. But facing some errors when launching the connector.

  • Unable to validate account permissions

  • Provided bucket doesn’t exist

I have double checked the configs and not sure how to further troubleshoot and make the fixes.

Can someone please guide me?


Hi @krisrr3 .
Welcome to the Confluent community forum!

Are you using the source connector or sink connector?

Hi @vnadkarni ,

Thanks for the reply. Its Sink connector

Hi @krisrr3 . I just did this myself - used a datagen source and a AWS S3 sink connector and saw my data in the S3 bucket. Looks like you’re doing this in the Confluent Cloud web UI (as I did). Can you walk me through the steps you’re taking?

Hi @vnadkarni ,

thanks. Let me explain

  1. First created a topic and published a message to it
  2. Created a Service Account and Api key
  3. Granted the service account access to the topic
  4. The started the connector with the service account

I’ll post the details of the AWS Settings as a next step, might be good to solve one part at a time.

thanks again for your help.

1 Like

ok replying to my own post, I solved it by creating the API Key and Secret while creating the Connector and not separately, as I did before.

In all honesty, it was called out in the pre-requisites.

Will move on to investigate the problem with AWS S3 side, as I am still getting the exception. Provided bucket doesn’t exist


Found the other problem, its actually the name of the S3 bucket and not the ARN.

thanks @vnadkarni for helping anyway.


Glad to know that you’ve fixed it! :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.