Kafka connect isn't seeing the plugin class

I’m new to Kafka. I’m trying to run the quick start guide. Kafka worked, but I’m having an issue with Kafka connect. In the config/connect-standalone.properties file I set plugin.path to point to the libs folder. I tried this with a relative path and explicit. But Kafka still doesn’t seem to see the connector class.

Here is the error: “Failed to find any class that implements Connector and which name matches FileStreamSource”

It also lists connectors it does see, which include names of things I don’t see in the libs folder. Like MirrorCheckpointConnector, MirrorHeartbeatConnector, MirrorSourceConnector, MockSinkConnector…

I’ve been reading the documentation and a few other guides. It seems like this should be pretty simple, so I’m not sure what I’m doing wrong.

I downloaded Kafka 2.12-3.2.0 and placed it on a new Ubuntu 20.04

hey @horseatingweeds

welcome :slight_smile:

could share some details of your setup?
docker or onprem setup?

did you follow this guide?
https://docs.confluent.io/platform/7.1.1/connect/quickstart.html

if on prem, what does
confluent local services connect connector list
say?

best,
michael

Hi Michael,

This is a local Ubuntu VM. I downloaded Kafka from here: https://dlcdn.apache.org/kafka/3.2.0/kafka_2.12-3.2.0.tgz -O ~/kafka/kafka3.2.0.tgz

And followed this guide: Apache Kafka

Which went smooth until step 6 where you use these file connectors to stream in from a file and then out to a file.

Thanks,

Ben

Hi,

maybe a quick win:
did you copy paste the plugin path config parameter?
I’ve just double checked and the docs seem to miss a “s”.

docs state

echo “plugin.path=lib/connect-file-3.2.0.jar”

should be

echo “plugin.path=libs/connect-file-3.2.0.jar”

hth,
michael

Man, Michael… That was it. I didn’t copy and paste the the path – or maybe I did at one point – but I guess all the paths I tried were missing the “s” or had some other problem.

This one is working: plugin.path=/usr/local/share/java,/usr/local/share/kafka/plugins,/opt/connectors,/home/ben/kafka/kafka_2.12-3.2.0/libs

Thanks!

1 Like