V2 REST API returns 404 Not Found

Hello, I’m using Confluent managed Kafka service and issuing V2 REST API calls but its returning 404 Not Found error. When switch to V3 REST api, call is returning successfully. Given that V3 REST calls are successful, I doubt this is a API key issue.
As per my understanding, topic partition offset api is only supported in V2 and its not supported in V3.

Below are the api call signature for both api’s

Failed V2 REST Call. (Note: other V2 api calls, for example /topics, are failing with same error) Please make a note that I have already tried call with Confluent Cloud API key but I still get same error)

curl \
  -X GET \
  -H "Accept: application/vnd.kafka.v2+json, application/vnd.kafka+json, application/json" \
  -H "Content-Type: application/vnd.kafka.v2+json" \
  -H "Authorization: Basic *******" \
  https://***-*****.us-east4.gcp.confluent.cloud:443/v2/clusters/***-******/topics/*********/partitions/0/offsets

Successful V3 REST Call:

curl \            
  -X GET \
  -H "Content-Type: application/json" \                                                     
  -H "Authorization: Basic *****" \
  https://***-******.us-east4.gcp.confluent.cloud:443/kafka/v3/clusters/***-******/topics

Thank you in advance.